Missing Keyword Ranking Data
Incident Report for Raven
Postmortem

Google has announced that the CSV Download will no longer be available starting October 20, 2015. Therefore, it is essential that we move to use the Search Analytics API, as quickly as possible to avoid losing access for any of our customers.

This API will replace the CSV Downloads that our toolsets have relied upon since their release. However, as it is a new API, there have been several issues that our team has been working through related to performance and error handling. We have been in communication with other development teams that are using the new Search Analytics API as well who have confirmed that the issues are with the API itself.

Our team's full attention is on making this work with as little interruption for our customers as possible. Many of the issues have been quickly resolved once brought to the attention of Google's engineering team. Others require more attention.

To be clear, our commitment is to delivering accurate and timely Keyword Ranking data for our customers to use in their reports. We will continue to work with Google's team to achieve this objective.

Posted Sep 04, 2015 - 14:41 CDT

Resolved
We are continuing to monitor this incident. We have seen a sharp reduction on the number of API-reported errors and are seeing that reported cases of missing data are beginning to resolve. Please contact us at help@raventools.com if you need assistance.
Posted Sep 04, 2015 - 14:11 CDT
Monitoring
Customers connecting new campaigns may experience a delay in retrieving the initial 60 days worth of keyword ranking data from Google Webmaster Tools. We are working with the API team for a resolution.
Posted Sep 03, 2015 - 12:49 CDT