Google Analytics 4 New Property Type “App+Web”
Incident Report for Raven
Update
We are continuing to work on a fix for this issue.
Posted Nov 11, 2020 - 19:00 CST
Identified
Google Analytics has publicly released the new Google Analytics 4 platform which leverages a new Property Type, “App+Web”. Historically, Google Analytics properties were limited to the “Universal Analytics” type.

You have the ability to create new properties with the new type or you can upgrade the legacy “Universal Analytics” property type to the new “App+Web” type.

Before you move down this path, please note that once you have upgraded to “App+Web”, you cannot downgrade back to “Universal Analytics” and Raven does not yet have a connector with access to performance data from the new “App+Web” property type.


Why?
The legacy data for Google Analytics “Universal Analytics” properties come through the Google Analytics Core Reporting API Version 4 (https://developers.google.com/analytics/devguides/reporting/core/v4). The new “App+Web” data will be available from a new API that is currently in pre-release, the Analytics Data API (https://developers.google.com/analytics/trusted-testing/analytics-data).


What do I do?
Raven encourages you not to leverage the new property type for those entities that you need to report on within the Raven reports in the immediate to near term to ensure that your data continues to flow through the “Universal Analytics” property.

If you have already upgraded your properties or created new properties that you need for reporting, you will have to create a new property under the "Universal Analytics" type.


What is Raven doing about it?
We’re working closely with our Google contacts to understand when the Analytics Data API will be available publicly. In the interim, we’re looking to make as much progress on a new connector as we can ahead of the public release.

Raven will be updating this post as new information becomes available - if you have any questions at all, please don’t hesitate to contact us at help@raventools.com.
Posted Nov 10, 2020 - 17:26 CST
This incident affects: Campaign (Google Analytics).